Macbook에 설치한 우분투 업데이트를 하면 Wi-Fi를 사용할 수 없게 되었다

Macbook에 설치한 우분투 업데이트를 하면 Wi-Fi를 사용할 수 없게 되었다

2022-10-06 last update

5 minutes reading WiFi ubuntu16.04
MacbookAir에 듀얼 부팅으로 설치된 Ubuntu를 업데이트하면 Wi-Fi를 사용할 수 없습니다. 메뉴에서 Wi-Fi가 사라졌습니다.
(OS는 Ubuntu이지만 GUI는 LXDE를 사용합니다.)



주의



이 작업을 수행하려면 Wi-Fi 이외의 네트워크에 연결하는 방법을 확보해야 합니다.
Ubuntu는 iPhone이나 WiMAX라면 USB-Ether로서 디바이스를 인식시켜 인터넷에 접속할 수 있으므로, 사전에 동작 확인해 둡시다.

Wi-Fi 드라이버 재설치



Wi-Fi 드라이버를 다시 설치하는 명령이지만, 이것을 실행해도 오류로 중지됩니다.
sudo apt-get install --reinstall bcmwl-kernel-source

로그 파일 내용


sudo apt-get install --reinstall bcmwl-kernel-source
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/1,126 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 225024 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.141+bdcom-0ubuntu2_amd64.deb ...
Removing all DKMS Modules
Done.
Unpacking bcmwl-kernel-source (6.30.223.141+bdcom-0ubuntu2) over (6.30.223.141+bdcom-0ubuntu2) ...
Setting up bcmwl-kernel-source (6.30.223.141+bdcom-0ubuntu2) ...
Loading new bcmwl-6.30.223.141+bdcom DKMS files...
Building only for 3.16.0-31-generic
Building for architecture x86_64
Building initial module for 3.16.0-31-generic
Error! Bad return status for module build on kernel: 3.16.0-31-generic (x86_64)
Consult /var/lib/dkms/bcmwl/6.30.223.141+bdcom/build/make.log for more information.
modprobe: FATAL: Module wl not found.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
update-initramfs: Generating /boot/initrd.img-3.16.0-31-generic

sudo modprobe wl
modprobe: FATAL: Module wl not found.

최신 버전의 드라이버 패키지를 다운로드합니다.



내 경우에는 18.04 용이지만이 페이지에서 최신 패키지를 다운로드했습니다.

여기를 클릭하여 패키지를 다운로드합니다.


이 패키지 설치


cd ~/ダウンロード
sudo apt-get install ./bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu4_amd64.deb

이 작업으로 올바르게 Wi-Fi 드라이버를 설치하고 사용할 수 있습니다.