【문제 1: conflicting requests】 CentOS 8.1(CentOS-8.1.1911) 설치 후 dnf 명령으로 발생하는 오류 해결

【문제 1: conflicting requests】 CentOS 8.1(CentOS-8.1.1911) 설치 후 dnf 명령으로 발생하는 오류 해결

2022-10-03 last update

5 minutes reading dnf 오류 해결 해결 방법 Yum CentOS8.1
CentOS-8.1.1911을 설치한 후 yum 명령이나 dnf 명령을 사용하면 다음 오류가 발생했습니다.

실행 결과
[[email protected] ~]# dnf list installed
モジュラーの依存に関する問題:

 問題 1: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBD-SQLite:1.58:8010020191114033549:073fa5fe-0.x86_64
 問題 2: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBI:1.641:8010020191113222731:16b3ab4d-0.x86_64
インストール済みパッケージ
GConf2.x86_64                              3.2.6-22.el8               @AppStream
ModemManager.x86_64                        1.10.4-1.el8               @anaconda
ModemManager-glib.x86_64                   1.10.4-1.el8               @anaconda
NetworkManager.x86_64                      1:1.20.0-3.el8             @anaconda
NetworkManager-adsl.x86_64                 1:1.20.0-3.el8             @anaconda
NetworkManager-bluetooth.x86_64            1:1.20.0-3.el8             @anaconda
NetworkManager-config-server.noarch        1:1.20.0-3.el8             @anaconda
~~~~~~~
~~ 省略 ~~
~~~~~~~
xz.x86_64                                  5.2.4-3.el8                @anaconda
xz-libs.x86_64                             5.2.4-3.el8                @anaconda
yajl.x86_64                                2.1.0-10.el8               @AppStream
yelp.x86_64                                2:3.28.1-3.el8             @AppStream
yelp-libs.x86_64                           2:3.28.1-3.el8             @AppStream
yelp-tools.noarch                          3.28.0-3.el8               @AppStream
yelp-xsl.noarch                            3.28.0-2.el8               @AppStream
yum.noarch                                 4.2.7-6.el8                @anaconda
zenity.x86_64                              3.28.1-1.el8               @AppStream
zip.x86_64                                 3.0-23.el8                 @anaconda
zlib.x86_64                                1.2.11-10.el8              @anaconda
[[email protected] ~]#


오류 문
問題 1: conflicting requests
- nothing provides module(perl:5.26) needed by module perl-DBD-SQLite:1.58:8010020191114033549:073fa5fe-0.x86_64
問題 2: conflicting requests
- nothing provides module(perl:5.26) needed by module perl-DBI:1.641:8010020191113222731:16b3ab4d-0.x86_64

일본어로 번역
問題 1: 競合するリクエスト
- モジュール「perl-DBD-SQLite:1.58:8010020191114033549:073fa5fe-0.x86_64」が必要とするモジュール(perl:5.26)を提供するものはありません。
問題 2: 競合するリクエスト
- モジュール「perl-DBI:1.641:8010020191113222731:16b3ab4d-0.x86_64」が必要とするモジュール(perl:5.26)を提供するものはありません。

됩니다.

따라서 다음 명령으로 perl : 5.26 모듈 스트림을 활성화했습니다.
dnf module enable perl:5.26
실행 결과
[[email protected] ~]# dnf module enable perl:5.26
メタデータの期限切れの最終確認: 2:13:30 時間前の 2020年04月21日 14時23分45秒 に 実施しました。
依存関係が解決しました。
================================================================================
 パッケージ        アーキテクチャー バージョン          リポジトリー      サイズ
================================================================================
モジュールストリームの有効化:
 perl                               5.26

トランザクションの概要
================================================================================

これでよろしいですか? [y/N]: y
完了しました!
[[email protected] ~]#

이로 인해 오류가 해결되었습니다.

실행 결과
[[email protected] ~]# dnf list installed
インストール済みパッケージ
GConf2.x86_64                              3.2.6-22.el8               @AppStream
ModemManager.x86_64                        1.10.4-1.el8               @anaconda
ModemManager-glib.x86_64                   1.10.4-1.el8               @anaconda
NetworkManager.x86_64                      1:1.20.0-3.el8             @anaconda
NetworkManager-adsl.x86_64                 1:1.20.0-3.el8             @anaconda
NetworkManager-bluetooth.x86_64            1:1.20.0-3.el8             @anaconda
NetworkManager-config-server.noarch        1:1.20.0-3.el8             @anaconda
~~~~~~~
~~ 省略 ~~
~~~~~~~
xz.x86_64                                  5.2.4-3.el8                @anaconda
xz-libs.x86_64                             5.2.4-3.el8                @anaconda
yajl.x86_64                                2.1.0-10.el8               @AppStream
yelp.x86_64                                2:3.28.1-3.el8             @AppStream
yelp-libs.x86_64                           2:3.28.1-3.el8             @AppStream
yelp-tools.noarch                          3.28.0-3.el8               @AppStream
yelp-xsl.noarch                            3.28.0-2.el8               @AppStream
yum.noarch                                 4.2.7-6.el8                @anaconda
zenity.x86_64                              3.28.1-1.el8               @AppStream
zip.x86_64                                 3.0-23.el8                 @anaconda
zlib.x86_64                                1.2.11-10.el8              @anaconda
[[email protected] ~]#


이상